Back to overview

Increased levels of card fraud

Feb 23 at 04:16pm AEST
Affected services
Storapp (production)

Resolved
Feb 24 at 04:27pm AEST

Payment services have successfully been restored

Created
Feb 23 at 04:16pm AEST

We have detected elevated levels of credit card fraud and are adjusting security settings to compensate. Some legitimate payments in StorApp may fail to go through while we work on this issue.